mount bubba in ubuntu

Got problems with Bubba? Then this forum is for you.
pelle
Posts: 20
Joined: 14 Mar 2007, 18:46

mount bubba in ubuntu

Post by pelle » 17 Mar 2007, 17:10

trying to mount my bubba on a laptop recently installed with xubuntu
note: i am a beginner at linux

so far I have tried (in terminal window):
first:
sudo apt-get install smbfs
then mount with:

sudo mount -t smbfs //bubba_ip/web-admin/filemgr.php?path=/home/storage/ -o username=xyz,password=xyz,uid=yyy=gid=yyy

all i get is a error message "man 8 mount to many details"

help is appreciated

/bubba - loving it!

bjorn
Posts: 88
Joined: 03 Jan 2007, 09:02

Post by bjorn » 17 Mar 2007, 19:02

syntax is "mount <device> <mountpoint>"

that would translate to something like this (assuming that directory /mnt/bubba excists):

sudo mount -t smbfs -o username=xyz,password=xyz,uid=yyy,gid=yyy //bubba_ip/storage /mnt/bubba

/Bjorn

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 18 Mar 2007, 11:26

A quick note here,

If you are planning on using this in your fstab on your ubuntumachine. You should avoid stating your username and password in this file. Instead use credentials option to add this information to a file not readable by everyone on your system.

A googled article on this: http://www.justlinux.com/nhf/Filesystem ... ently.html

Look under the paragraph "Providing Security"

/Tor
Co-founder OpenProducts and Ex Excito Developer

pelle
Posts: 20
Joined: 14 Mar 2007, 18:46

Post by pelle » 19 Mar 2007, 15:00

thanks for your support

I tried Björns suggestion - didnt help I am afraid

will read on in article suggested by Tor

I have a feling this is something to do with my LAN setup

As a beginner to Linux, I would wish for a simple "explorer" view to see and, if neccessary, mount any drive accesible on the LAN network

edit: any suggestions for: //servername/sharename /mountdirectory ?
should I try //Bubba/storage/ /music ?

Filip
Posts: 30
Joined: 06 Feb 2007, 12:27
Location: Lund, Sweden

Post by Filip » 31 Aug 2007, 06:38

Did you solve it pelle?

pete_kirkham
Posts: 1
Joined: 07 Sep 2007, 19:13

Post by pete_kirkham » 07 Sep 2007, 21:59

I don't know about differences between Xubuntu and Ubuntu, but on Ubuntu the server appears in Nautilus when you choose Places > Network, as ftp, sftp and is also under Windows network. Browsing into the server, it requests user and password as expected, adds them to the keychain, then shows the files.

For a one-off mount:

Code: Select all

mount -t smbfs //bubba/home /net/bubba/home -o username=*****,password=***** 
works for me.

I think that the ? you've got where you copied the URL for the web-admin console is confusing mount's command line processing causing the 'too many details' error; if you want the web files, they'd be under the mount point in the web folder.

Following the instructions at justlinux.com for adding to /etc/fstab, the followin works with mount -a when run as root:

Code: Select all

//bubba/home    /net/bubba/home     smbfs credentials=/home/pete/.sambacreds,uid=pete 0 0
//bubba/storage /net/bubba/storage  smbfs credentials=/home/pete/.sambacreds,uid=pete 0 0
On next reboot, the mount points appear in Nautilus, but you can't mount them as a user.

To get mount working for users, you need to set suid root on smbmnt and ensure that the mount point is owned by the user doing the mounting.

I haven't tried enabling mounts for more than one account; if you add lines to fstab for each user, it adds icons for the mount points to everyone's accounts; trying to use ~ for the mount point and credentials doesn't seem to work either.


Pete

pelle
Posts: 20
Joined: 14 Mar 2007, 18:46

Post by pelle » 14 Aug 2008, 09:45

bump :-)

I tried to mount Bubba in Hardy but with no luck using this:

Code: Select all

 sudo mount -t smbfs //bubba/storage /home/bubba/storage -o username=*****,password=***** 
Error message:
mount error: could not find target server. TCP name bubba/storage not found. No ip address specified and hostname not found
Edit: Using bubbas IP "192.168.0.x" instead of "bubba" and I guess it worked. I can access Bubba folders from my Hardy/Home directory now.

What I really want to do is mount Bubba/storage permanently. So I guess I have to read on...will try editing fstab as suggested...

Cohan
Posts: 21
Joined: 12 Aug 2008, 15:42

Post by Cohan » 14 Aug 2008, 19:45

pelle wrote:[...]
What I really want to do is mount Bubba/storage permanently. So I guess I have to read on...will try editing fstab as suggested...
Permanent mounts are specified in /etc/fstab so you are correct to start digging there. Use the auto flag to have the mounting done automaticly at boot time.

Example:

Code: Select all

//bubba/storage /net/bubba/storage  smbfs credentials=/home/pete/.sambacreds,uid=pete,auto 0 0

ahoff
Posts: 80
Joined: 01 Apr 2008, 20:50
Location: Swe
Contact:

Post by ahoff » 15 Aug 2008, 10:52


pelle
Posts: 20
Joined: 14 Mar 2007, 18:46

success!

Post by pelle » 09 Nov 2008, 01:32

Finally it worked.

I followed the advise in http://www.marcus-furius.com/?p=59

The line(s) added in fstab-file looks like this

//[bubbaip]/storage/music /home/[ubuntu-user]/Music/ cifs nounix,uid=[ubuntu-user],gid=[ubuntu-user],file_mode=0777,dir_mode=0777, username=[bubbashare-user],password=[bubbashare-password]

(And yes; use credentials if you dont like listing your password in the fstab-file)

Ruud
Posts: 3
Joined: 15 Nov 2008, 14:14

mount returns error

Post by Ruud » 15 Nov 2008, 14:27

I want to mount my Bubba and decided to first try a one-time mount before going for the permanent one.
I tried to mount Bubba using the following command:
mount -t smbfs //bubba/home /mnt/mountedbubba -o username=abcd,password=efgh

This gives the following message back:
mount: wrong fs type, bad option, bad superblock on //bubba/home,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

dmesg gives some information, but I don't have a clue what to do with it:
smbfs: mount_data version 1919251317 is not supported

Can anyone help?? Thanks

Ruud

6feet5
Posts: 269
Joined: 13 Apr 2007, 17:32
Location: Gnesta, Sweden
Contact:

Post by 6feet5 » 15 Nov 2008, 14:48

Hi,

Try with 'cifs' instead of 'smbfs'.

Code: Select all

mount -t cifs //bubba/home /mnt/mountedbubba -o username=abcd,password=efgh
/Johan

Ruud
Posts: 3
Joined: 15 Nov 2008, 14:14

cifs doesn't work

Post by Ruud » 15 Nov 2008, 15:42

Hi,
thanks for the suggestion, but it doesn't help:

mount error: cifs filesystem not supported by the system

Ruud

6feet5
Posts: 269
Joined: 13 Apr 2007, 17:32
Location: Gnesta, Sweden
Contact:

Post by 6feet5 » 15 Nov 2008, 18:01

Hello again,

I'm no Ubuntu expert but it sounds like you're missing the package that support cifs. Kind of weird, but it appears you need the smbfs package, is it installed? If so, then I have no clue. Maybe someone here that is familiar with Ubuntu can help you...

/Johan

pelle
Posts: 20
Joined: 14 Mar 2007, 18:46

Post by pelle » 19 Nov 2008, 14:24

ruud: did you follow the instructions in my post above?
I.e. the instructions at: http://www.marcus-furius.com/?p=59

1. Install samba
2. Make a directory in your (note!) home-folder

If I remember correctly, mounting bubba in /mnt/folder did not work for me. When I tried mounting in /user/home all was well.
(Something to do with file permissions in default Ubuntu 8.04, I guess)

Locked