PHP-Fusion under Etch

A collection of tips on howto tweak your Bubba.
Post Reply
Eek
Posts: 372
Joined: 23 Dec 2007, 03:03
Location: the Netherlands

PHP-Fusion under Etch

Post by Eek » 13 Apr 2008, 08:04

This how-to describes the solution for running PHP-Fusion under Debian Etch.
The reason for this how-to is a bug in the default installed MySql server version under Etch.
This causes functional problems in PHP-Fusion, but also in any application which is using MySql and a LEFT JOIN.

Upgrade
You have PHP-Fusion already installed and are using or have used the dist upgrade option to upgrade from Sarge to Etch.
After the upgrade, you should upgrade MySql server using the etch-backport repository.

Code: Select all

vi /etc/apt/sources.list
Add the etch-backport repository (you are of-course free to choose another one)
deb http://backports.sipo.nl/ etch-backports main
Now add the key for this repository, update apt and upgrade MySql server

Code: Select all

$ cd /tmp
$ wget http://backports.sipo.nl/archive.key
$ apt-key add archive.key
$ apt-get update
$ apt-get -t etch-backports install mysql-server
You should be getting something like this
bubba:/tmp# apt-get -t etch-backports install mysql-server
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
libmysqlclient15off mysql-client mysql-client-5.0 mysql-common mysql-server-5.0
Suggested packages:
tinyca
Recommended packages:
libterm-readkey-perl libhtml-template-perl
The following NEW packages will be installed:
mysql-client-5.0 mysql-server-5.0
The following packages will be upgraded:
libmysqlclient15off mysql-client mysql-common mysql-server
After you enter Y to continue, just press enter on the other questions you get.
The MySql server version should now be:

Code: Select all

dpkg --list |grep mysql
ii libdbd-mysql-perl 3.0008-1 A Perl5 database interface to the MySQL data
ii libmysqlclient15off 5.0.51a-3~bpo40+1 MySQL database client library
ii mysql-client-5.0 5.0.51a-3~bpo40+1 MySQL database client binaries
ii mysql-common 5.0.51a-3~bpo40+1 MySQL database common files
ii mysql-server 5.0.51a-3~bpo40+1 MySQL database server (meta package dependin
ii mysql-server-5.0 5.0.51a-3~bpo40+1 MySQL database server binaries
ii php5-mysql 5.2.0-8+etch10 MySQL module for php5
Install
You have installed or used the dist upgrade and are currently on Etch and want to install PHP-Fusion.
You can use the How to Create a PHP-Fusion cms website http://forum.excito.net//viewtopic.php?t=854
with the following adjustments:

1. Install the MySql server using the paragraph described above.
2. Create the phpfusion user, using the following commands

Code: Select all

mysql>  insert into user values ('localhost','phpfusion',password('changeme'),'Y','Y','Y','Y','Y','Y','N','N','N','N','N','N','N','Y','N','N','Y','Y','Y','N','N','N','N','N','N','N','N','N','N','N', 0, 0, 0, 0);
mysql> flush privileges;
mysql> create database phpfusion;
mysql> exit 
Cheers
Eek

Post Reply