Upgrading PHP4

Got problems with Bubba? Then this forum is for you.
Locked
Mats
Posts: 2
Joined: 31 Jul 2007, 03:39
Location: Stockholm, Sweden

Upgrading PHP4

Post by Mats » 31 Jul 2007, 03:48

Hi,

I'm trying to install sugarcrm 4.5.1e, however that software needs php 4.3.11 or higher and I have 4.3.10-22 installed.

aptitude does not show any newer versions available.

ps.
I've run apt-get update, and upgrade
ds.


Any ideas on how this can be solved ?

TIA

/Mats

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 02 Aug 2007, 17:40

Since Bubba run Debian Sarge or old stable as its also called now. You wont get any newer versions of php that way.

You have a few options. Either install php5 from http://backports.org wich unfortunately conflicts with the Bubba software ie the web-admin ui which requires php4 atm. Otherwise wait for the Excito upgrade to Debian Etch which contains php5.

/Tor
Co-founder OpenProducts and Ex Excito Developer

Mats
Posts: 2
Joined: 31 Jul 2007, 03:39
Location: Stockholm, Sweden

Post by Mats » 02 Aug 2007, 18:10

tor wrote:Otherwise wait for the Excito upgrade to Debian Etch which contains php5.

/Tor
Thanks for your reply.

Do you have a time estimate for when that update will be available ?

/Mats

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 08 Aug 2007, 08:13

Hi Mats,

I can't give you an exact time when we have an etch-installer ready. But we are talking in the comming weeks, if we are lucky.

/Tor
Co-founder OpenProducts and Ex Excito Developer

yooakim
Posts: 43
Joined: 08 May 2007, 08:58

Etch installer?

Post by yooakim » 03 Oct 2007, 15:29

Any comment son when an Etch installer can be ready?

Cheers,
Joakim

tor
Posts: 703
Joined: 06 Dec 2006, 12:24
Contact:

Post by tor » 05 Oct 2007, 14:03

Hi yooakim and others,

Sorry for not keeping you updated on this. As you have understood the upgrade has taken a bit longer than we wanted.

The base-install is more or less working. But we have run in to some problems with a few of our applications on upgrade, for example the upnp server mediatomb wont run with our config when compiled for Etch. This is most likely due to a lot of tools and libraries being upgraded. None of these problems are of any major type but unfortunately takes time to fix.

We are working as hard as we can to get this fixed and will try to get it out the door asap. (Thanks for being so patient.)

/Tor
Co-founder OpenProducts and Ex Excito Developer

nb000
Posts: 20
Joined: 29 May 2008, 14:40

debian update

Post by nb000 » 02 Jun 2008, 05:45

I have a simple question:
the current bubba linux is based on Sarge or Etch?

microcode
Posts: 4
Joined: 29 May 2008, 01:51

Post by microcode » 03 Jun 2008, 16:45

nb000,

Bubba currently is based on sarge, but the folks at exctio are working on an upgrade to etch.

There are test versions of the etch install images available, as described in this other thread.
Note that these install images will format your hard drive, so make any necessary backups of your data first if you choose to use one of them.

I'm using the minimal etch install and I have not had any problems with it.

Locked